Russ

Pixel Exit Staff
#1
First off let me start by saying thank you for your patience. We've been slammed with custom work over the past few months which is fantastic but we haven't pushed out the updates we've wanted to. We've been also working on some cool new things for XenBase that we'll be putting into the final version of the 1.5 release.

Regarding 1.4.8:
This is a small release which fixes various bugs and brings a few small improvements.
  • Fixed a bug with deleted redirected threads
  • Floating nav should adjust in conversation views now as well
  • Fixed BBCode/Quote Boxes bottom margin (bbCodeBlock may need reverting)
  • Fixed a bug in regards to floating just the main nav, the sub-nav JS would not work appropriately.
  • Minor profile page CSS adjustment
  • Minor QuickSearch CSS adjustment in Search Nav Tab mode
  • Added properties for the following "phrases"
    • Mark Forum Read - When Node Icon is trigger for mark forum read
    • New Admin Post - For messages when New Admin Post indicator is enabled
  • Added xb_custom_js_body and xb_custom_js_head for custom JS
We'll be pushing out the 1.4.8 updates over the course of today. As with all updates ALWAYS make a backup first. Backup your XenBase/Style/Child Style. For this version you'll want to upload the new xenbase folder.

For further detailed instructions on upgrading all should be able to view this guide.

Regarding 1.5.0 Beta 1:
We're usually in the same boat as XenForo when it comes to Beta's. We won't be pushing out an official version but for those of you who are upgrading to 1.5.0 Beta 1 I'll be putting up a version of the updated XenBase. To use it of course make a backup of your styles first, then just import and overwrite XenBase. You may still have an outdated template but you can use the merge function.

The XenBase 1.5.0 Beta 1 version can be found here. (link coming soon)

Forum Permissions
Over the past week we've made some changes to the forum setup and specifically our client area. While we think we covered everyone if you find out that you no longer have access to our forum support but have an active license, please submit a support ticket so we can take care of you.
 
Last edited:

Russ

Pixel Exit Staff
#3
I updated my test site to XF 1.5.0 beta with Blackend Pro 1.4.7 without any templates or phrases needing fixing.
Did you use the merge feature at all? My install showed quite a few templates outdated(mainly because of the trophy enable/disable option)
 
#6
I've just upgraded my test site (Running FragZone) and I had those warnings also for XenBase. It let me merge most of them except for the (If I remembered correctly) "message_user_info".
 
#7
You may want to recheck what you did,
Uploaded xf 1.5.0 beta, ran install, went to acp when done, no warning of outdated templates, checked for outdated templates, none found. If I have time later today I will reinstall backup of xf 1.4.8 and test install of xf 1.5.0 beta again. So far so good :)
 

Steve

Pixel Exit Staff
#8
Strange, there might actually be a bug with 1.5 then. We haven't updated our dev board but are working from a fresh 1.5 install and just importing XenBase to that.
 

Russ

Pixel Exit Staff
#14
But struggle with "message_user_info" template, as it wont merge, and have to be done manually.
I believe all you need to do is change the conditional around the trophy part:

Code:
        <xen:if is="@messageShowTrophyPoints AND {$user.user_id} AND {$xenOptions.enableTrophies}">
           <dl class="pairsJustified xbTrophyPoints">
             <dt><xen:if is="@xb_fa_messageUserInfo"><i class="fa fa-trophy fa-fw Tooltip" title="{xen:phrase trophy_points}" data-offsetX="-6" data-offsetY="0"></i><xen:else />{xen:phrase trophy_points}:</xen:if></dt>
             <dd><a href="{xen:link 'members/trophies', $user}" class="OverlayTrigger concealed">{xen:number $user.trophy_points}</a></dd>
           </dl>
         </xen:if>
 
#15
I believe all you need to do is change the conditional around the trophy part:

Code:
        <xen:if is="@messageShowTrophyPoints AND {$user.user_id} AND {$xenOptions.enableTrophies}">
           <dl class="pairsJustified xbTrophyPoints">
             <dt><xen:if is="@xb_fa_messageUserInfo"><i class="fa fa-trophy fa-fw Tooltip" title="{xen:phrase trophy_points}" data-offsetX="-6" data-offsetY="0"></i><xen:else />{xen:phrase trophy_points}:</xen:if></dt>
             <dd><a href="{xen:link 'members/trophies', $user}" class="OverlayTrigger concealed">{xen:number $user.trophy_points}</a></dd>
           </dl>
         </xen:if>
It worked when I opened the template, and saved it, then merged it...? Dont know why. But its no more templates thats not updated.
This was on 1.5.0 beta though, not my 1.4.8 prod site.

Might be the reason.
 
#17
I've been out of town for the weekend and didn't get to Apex/Blackend Pro updates when I pushed out the others. I'll push them out here shortly.

1.5 version won't be coming until XF releases their "stable" version of it.
This was posted 2 weeks ago so maybe the remaining style updates for 1.4.9 will be posted shortly.
 

Russ

Pixel Exit Staff
#18
Will Xenbase be released for 1.4.9? Or waiting for 1.5.0 now?
Nothing changed in 1.4.9 // 1.4.10 so we're putting the focus on 1.5.0 "stable" release.

I'm not sure if we'll see another Beta for 1.5, usually they get up to 4-5 betas then we see the final release. So here's hoping to a 1.5 release soon :D.

My own theory is the reason we saw 1.4.10 was primarily for the security release(all assumption of course).

So the next releases for all of our styles will be for the 1.5 versions. The styles released currently on our site will work on 1.4.5/1.4.6/1.4.7/1.4.8 fine with zero outdated templates.
 

Pre-Sale Questions

If you have any questions or concerns you want to ask before you make a purchase don't hesitate to use one of our multiple support channels for your convenience.