XF 1.x Article on Forum page

Bionic Rooster

Registered
Hi guys, I just featured an article (AMS) and put it on the forum page. the box? is not the same as Random Media.
any fix would be greatly appreciated, thanks
Screenshot_1.jpg
 

Russ

Pixel Exit Staff
I'll need access to view it, the test user I had didn't have access to it(required to make an introduction post).

I don't have AMS installed at the moment
 

Russ

Pixel Exit Staff
Try doing this... and it may help if any other blocks get added.

Go to Style Properties: [XB] Forum List & Category -> Forum List Section Main, remove the background color(transparent), padding: 0px and border-style none. Basically remove any custom CSS set there. Then add this to your extra.css:

Code:
#forums.nodeList.sectionMain {
  background-color: transparent;
  padding: 0;
  border-style: none;
}

See if that helps.
 

Russ

Pixel Exit Staff
For one, you need to remove the padding: 0, and make the border-style: none just set it to blank.

Interesting about the background.... looking at blackend on my site I don't see the CSS on that screenshot either but it is loading. Can you do this, set it to any color, save the property, then open the background color and clear it, and save again.
 

Bionic Rooster

Registered
@Russ I ran into the same problem with Detour and the Article block. I tried the same changes you suggested for Blackend Pro but they didn't work
Can you tell me how to get the title block looking the same as the others?
Screenshot_4.jpg

Thanks :)
 

Russ

Pixel Exit Staff
Bob has an update coming on his add-ons I believe which address styling issues, in the meantime can you enable Test user on your site for me :).
 

Russ

Pixel Exit Staff
So I changed his code up a bit, I'll write him as well to see if he may want to adjust it.

Code:
    <div class="amsModuleTitle {xen:if $moduleTitleNode, 'nodeInfo categoryNodeInfo categoryStrip'}">
         <h3 class="{xen:if $moduleTitleNode, 'nodeTitle', 'subHeading'}">
           {xen:if $moduleTitleNode, '<a href="{xen:link ams}">{xen:raw $moduleTitleNode}</a>', {xen:raw $moduleTitle}}
         </h3>
     </div>

Add the traditional categorytext:

Code:
    <div class="amsModuleTitle {xen:if $moduleTitleNode, 'nodeInfo categoryNodeInfo categoryStrip'}">
       <div class="categoryText">
         <h3 class="{xen:if $moduleTitleNode, 'nodeTitle', 'subHeading'}">
           {xen:if $moduleTitleNode, '<a href="{xen:link ams}">{xen:raw $moduleTitleNode}</a>', {xen:raw $moduleTitle}}
         </h3>
       </div>
     </div>

Seems to be working, technically Detour just uses that extra div to add styling.
 

Pre-Sale Questions

If you have any questions or concerns you want to ask before you make a purchase don't hesitate to use one of our multiple support channels for your convenience.