XF 1.x [CORE] Lost gradient in user banners after EXTRA.css edit?

haqzore

Customer
I created a new usergroup, Adept Member.
In user banner styling, i selected OTHER and entered: userBanner AdeptMember


In EXTRA.css i have:
Code:
.userBanner.AdeptMember
{
color: brown;
background-color: gold;
border-color: brown;
}
Now, all of my banners seem to have lost the gradient?
Capture.PNG
 

Russ

Pixel Exit Staff
Technically we remove the XF gradient by replacing the default gradient with a blank image.

transparent url('styles/core/xenforo/gradients/form-button-white-25px.png') repeat-x top

That image there, you'll need to copy it from the /styles/default/xenforo/gradients/ folder to the core folder.
 

haqzore

Customer
i copied it to:
/styles/core/form-button-white-25px.png

is that correct? seems the issue is still occurring.
 

haqzore

Customer
thank you.

now i have: /styles/core/gradients/form-button-white-25px.png

i had to create the directory, as it didnt exist. this is the onlybfile in it.
this did not fix the issue, it is still occurring.

another question: is there another way i should have created this group banner? this seems complicated?
 

Russ

Pixel Exit Staff
You're going to hate me...

The folder is:

styles/core/xenforo/gradients/

Move the image into that folder.

It's not exactly complicated I'm just giving you bad instructions to get that gradient back :D.
 

haqzore

Customer
its already there it seems?

/styles/core/xenforo/gradients/form-button-white-25px.png

did i unintentionally make a bad edit possibly? i dont understand why even the default group banners lost transparency just because i created a new one in extra.css?

i'm clearly not the expert, just seems weird having to go through this simply from adding a usergroup style?

thanks for the help a always!
 

Steve

Pixel Exit Staff
Overwrite it using the image from the default style folder @Russ mentioned. Can't explain how it was there before but not now though. The image loading right now is a blank 1px X 1px image.
 

Russ

Pixel Exit Staff
We're not a fan of the original gradients XF uses on the style. Rather than removing every single call of that image we replaced it with a transparent 1x1 px image. The end goal if you want that gradient back would be to simply copy:

/styles/default/xenforo/gradients/form-button-white-25px.png

to:

/styles/core/xenforo/gradients/form-button-white-25px.png

Hope that makes sense.
 

haqzore

Customer
I'm sorry, I really think I'm making this more complicated than it has to be... Very sorry.

I don't necessarily want the standard XF styling, I just want whatever Core came with. I guess I didn't pay attention to the Core banner style.

Now that I look, I think my new style looks bad due to the different border color...

Final question - are my banner setups, as they stand now, the way Core comes? :) That is what I want.. I will make the new banner look good based on that.
 
Last edited:

Russ

Pixel Exit Staff
I'm sorry, I really think I'm making this more complicated than it has to be... Very sorry.

I don't necessarily want the standard XF styling, I just want whatever Core came with. I guess I didn't pay attention to the Core banner style.

Now that I look, I think my new style looks bad due to the different border color...

Final question - are my banner setups, as they stand now, the way Core comes? :) That is what I want.. I will make the new banner look good based on that.
Sorry for the late response, did you get this sorted?
 

Pre-Sale Questions

If you have any questions or concerns you want to ask before you make a purchase don't hesitate to use one of our multiple support channels for your convenience.