Lloyd Johnson

Registered
I'm attempting to use a Custom Field to store authorization codes for customers buying my software. The custom field exists but I cannot get it to display on either the Profile Details or Contact Details page. Here are my settings:

Custom User Fields > Edit Field > Basic Information > Display Location > Personal Details
Custom User Fields > Edit Field > General Options > The ONLY box that is checked is 'Viewable in message user info'
Style > Big Splash > Style Properties > Message Elements > 'Show custom user fields' is checked

As administrator, if I search for my my member account, I see that the field is populated. If I go to Personal Details or Contact Details, the field does not show.

Any idea as to what I am missing?
 

Russ

Pixel Exit Staff
Looking at your URL in your license it appears you've got this sorted out?

Screenshot_2.png


Is the PRO Suite - v3 the field you're trying to get on there?
 

Lloyd Johnson

Registered
Yes, the PRO Suite - v3 is the field I'm after and that is the test data I have in that field. But now I'm really puzzled. The field doesn't show on any of my pages at the website. But it does appear to show for you and that is really not what I want. I used this field in vBulletin to store the authorization code to unlock their software. I migrated the field from vB and it has populated it correctly in XF. But I only want to show this field to the logged in user.

Can it be set to be private data?

Also, can you tell me what you clicked on to see the image you posted? I've gone to my License page and I don't see this.
 

Russ

Pixel Exit Staff
Yes, the PRO Suite - v3 is the field I'm after and that is the test data I have in that field. But now I'm really puzzled. The field doesn't show on any of my pages at the website. But it does appear to show for you and that is really not what I want. I used this field in vBulletin to store the authorization code to unlock their software. I migrated the field from vB and it has populated it correctly in XF. But I only want to show this field to the logged in user.

Can it be set to be private data?

Also, can you tell me what you clicked on to see the image you posted? I've gone to my License page and I don't see this.
They are on all the posts logged out. I'm thinking you're browsing the site using a different style possibly?

http://woodturnerpro.com/community/index.php?threads/591/

That logged out I can see the custom user field. So you're wanting it so everyone logged in should be able to see it correct?
 

Lloyd Johnson

Registered
No. The authorization code is for that member ONLY. It is just like your license key. Whoever has that key can unlock the software. So only Lloyd Johnson should see the code for Lloyd Johnson.
BTW, now that I Can see that code, I'm moving it to the Contact Details page for obvious reasons.
Is it possible to make that field private for the owner of that forum account only?
 

Lloyd Johnson

Registered
OK, I think I've figured it out. If I uncheck the box 'Show custom user fields' in Style Properties > Message Elements, the data in the Custom Field will not show to the world.
And if I make it 'Editable to the user', it will appear on the user's Profile Details page.
I had not checked that box because I didn't want that field to be editable by anyone but an Administrator. If it's not editable, though, the field doesn't show. I can live with this. :->
My $.02 is that the field should always show but is either editable or not. Is there ever a reason for not showing a custom field?
Thanks for your help.
 

Russ

Pixel Exit Staff
OK, I think I've figured it out. If I uncheck the box 'Show custom user fields' in Style Properties > Message Elements, the data in the Custom Field will not show to the world.
And if I make it 'Editable to the user', it will appear on the user's Profile Details page.
I had not checked that box because I didn't want that field to be editable by anyone but an Administrator. If it's not editable, though, the field doesn't show. I can live with this. :->
My $.02 is that the field should always show but is either editable or not. Is there ever a reason for not showing a custom field?
Thanks for your help.
We use custom user fields for a variety of reasons and many will never show on the message user info. One thing could be... customization such as one of my tutorials in the Resources section on here. It lets you create a user field to allow users to toggle the floating navigation on / off, no point in letting that show on the message area.
 

Pre-Sale Questions

If you have any questions or concerns you want to ask before you make a purchase don't hesitate to use one of our multiple support channels for your convenience.