Not a Bug Extra button when replying to thread (XenBase)

Discussion in 'Closed Reports' started by jflory7, Dec 12, 2016.

  1. jflory7

    jflory7 Customer

    Before submitting a bug report we usually recommend trying to replicate the problem on a default XenForo style(if applicable) to eliminate the possibility of it being a bug related to our styles.


    Website address (optional): https://crystalcraftmc.com (however, I also see the issue on pixelexit.com too)
    Bug Report Details:
    When going to reply to a thread, there are three "fields" underneath the reply box. The left button is "Post reply", the right button is "More options…", and the middle space is a gray, un-clickable space. It seems like the placement of a button is shifted and not the whole thing went with it. Screenshots should make more sense of this.
    [​IMG]

    You can see this actually affects more buttons than I expected, like in this one here.
    [​IMG]

    Any ideas on this one?
     
  2. Steve

    Steve Designer

    If you look at your screenshot you can see a warning in your browser just under the bookmarks bar saying Adobe Flash plugin has crashed. That button is the upload a file button which is flash driven. So I can only assume it is client side related. Most likely your other report is as well client side.

    What browser and OS versions are you running?
     
  3. jflory7

    jflory7 Customer

    Ah, I think that is the case for this… it seems to be correlated. I found an update for Flash that I missed over the weekend and applied that, but still no better for me. I'm not sure if there's a whole lot that can be done on this. I get the same problem in XenForo proper, which I guess I should have tested first before reporting… :p

    I think that one may be separate. The bar appears for me briefly at the top of the page, and then quickly fades out. I also don't receive a notification about Flash crashing on non-thread pages where the sub-nav bar would appear.

    Firefox 50.0.2 with Fedora 25.
     
  4. bt012ss

    bt012ss Customer

    Try this ->
    Open a new Tab in FF and use the adress -> about:config
    Type in the search field -> dom.ipc.plugins.asyncdrawing.enabled
    Have a look to the red field, it should be -> false
    If it is -> true, change it with a double click, this solved my problem with the upload button.
    Reboot your PC.

    pixel42.jpg
     
    Steve likes this.
  5. Steve

    Steve Designer

    Can you test with another OS? I tried your site and it appears fine for me, I meant the other report is client side not related to Flash directly.
     
  6. jflory7

    jflory7 Customer

    Hmmm, looks like it's already set to false for me. :(

    I don't have another OS I can readily access right now, but I tried in Chromium and had no issues with the button.
     
  7. Russ

    Russ Designer

    Not technically a bug just the browser blocking flash from loading. Luckily... 1.5.12 comes default with an html5 uploader!
     
    jflory7 likes this.
  8. jflory7

    jflory7 Customer

    I saw this in the changelog, I was super excited to finally have this make it to XenForo! (y)
     
    Russ likes this.

Let's work together on your next project

Contact us today to talk about how we can help you