XF 1.x Font Awesome Node Icons

Boone

Well-Known Member
I have read this thread https://pixelexit.com/resources/how-to-change-font-awesome-node-icons.6/

but I'm obviously missing something. :depressed:

I have the proper things checked in Style Properties -> [XB] - Font Awesome

I'd like different (read and unread) node icons for each forum (like here).

LOL, I love everything you've done with this particular style, probably going to do my best to emulate it. The bold for unread thread in discussion list, the font type AND size. Hope I'm not too much of a bother.
 

Attachments

  • Screen shot 2014-09-27 at 1.49.21 PM.png
    Screen shot 2014-09-27 at 1.49.21 PM.png
    6.8 KB · Views: 15
  • Screen shot 2014-09-27 at 1.48.46 PM.png
    Screen shot 2014-09-27 at 1.48.46 PM.png
    6.5 KB · Views: 15
  • Screen shot 2014-09-27 at 1.48.15 PM.png
    Screen shot 2014-09-27 at 1.48.15 PM.png
    64.5 KB · Views: 16

Afterward

Customer
- Different icon for each node you may try this:
https://pixelexit.com/threads/change-fa-node-icons-for-each-node.1222/#post-5560

- The font type is PTsan and you can change it in your style properties settings
Code:
<link href='//fonts.googleapis.com/css?family=PT+Sans:400,700' rel='stylesheet' type='text/css'>

- For bold unread in discussion list and i think it is by default like that but anyway here is how its done, you can add this to extra.css
Code:
.discussionListItems .unread .title a {
font-weight: bold;
}

Hope i helped.
 

Boone

Well-Known Member
For font type is this the right place?
 

Attachments

  • Screen shot 2014-09-27 at 3.01.52 PM.png
    Screen shot 2014-09-27 at 3.01.52 PM.png
    23.8 KB · Views: 16

Boone

Well-Known Member
Yes but that will change it globally, if you want to change it for specific area in the theme then tell me.

So, Web Font Code will change globally. Like you suggested how to change for specific area.

Secondly, is PTsan used globally here?
 

Boone

Well-Known Member
I would like the font set up like it looks here.
 

Attachments

  • Screen shot 2014-09-27 at 9.08.27 PM.png
    Screen shot 2014-09-27 at 9.08.27 PM.png
    171.5 KB · Views: 14

Russ

Pixel Exit Staff
We use PT Sans, our setup looks like this via : [XB] General:
Screenshot_1.png


Code:
<link href='//fonts.googleapis.com/css?family=PT+Sans:400,700' rel='stylesheet' type='text/css'>

Code:
'PT Sans', sans-serif
 

Boone

Well-Known Member
Incredible difference. Thanks.

One more quickie question if I may. Is it my eyes or are the two screenies I provided not the same font size/type?
 

Attachments

  • Screen shot 2014-09-27 at 10.47.32 PM.png
    Screen shot 2014-09-27 at 10.47.32 PM.png
    34.3 KB · Views: 13
  • Screen shot 2014-09-27 at 10.47.19 PM.png
    Screen shot 2014-09-27 at 10.47.19 PM.png
    39.7 KB · Views: 13

Afterward

Customer
Add this to extra.css
Code:
.node .nodeLastPost {
font-size: @xb_fontsizem;
}
Style Properties- [XB] General Setup - Admin CP - XenForo.jpg

Or you can edit it via style properties:
Style Properties- Forum - Node List - Admin CP - XenForo.jpg
 

Afterward

Customer
Eh sorry i should have told you to use this instead to overwrite:
Code:
html .node .nodeLastPost {
font-size: @xb_fontsizem;
}
But doesn't really matter now since you fixed it ;D
 

Boone

Well-Known Member
I guess since I made the node section larger the new indicator seems chopped off a bit at the top. Anyway way to fix this?
 

Attachments

  • Screen shot 2014-09-28 at 9.08.07 AM.png
    Screen shot 2014-09-28 at 9.08.07 AM.png
    6.3 KB · Views: 13

Boone

Well-Known Member
I don't know kinda of still looks the same?
 

Attachments

  • Screen shot 2014-09-28 at 9.55.18 AM.png
    Screen shot 2014-09-28 at 9.55.18 AM.png
    6.4 KB · Views: 13

Pre-Sale Questions

If you have any questions or concerns you want to ask before you make a purchase don't hesitate to use one of our multiple support channels for your convenience.