#1
Greetings,

I'm interested in purchasing the Fusion Gamer skin, but noticed right above the "Add to Wishlist" button it is listed as "1.2.0" but further down in the Details window it is listed at "1.1.4 Compatible".

I just wanted to make sure it is indeed 1.2.0 compatible before the trigger!

Beautiful site and skins, btw (y).
 

Pre-Sale Questions

If you have any questions or concerns you want to ask before you make a purchase don't hesitate to use one of our multiple support channels for your convenience.