Need some feedback - Editor Icons

Discussion in 'General Discussion' started by Russ, Jan 9, 2016.

  1. Russ

    Russ Designer

    8,450
    1,949
    113
    In our next version of XenBase we want to include some icons for some third party plugins so users don't have to do them manually. By default we have Font Awesome Editor Icons enabled so when a plugin adds another BBCode button it'll look broken, we want to avoid this and cut off less setup work for users.

    If anyone could let us know what plugins they use that add an additional icon to the editor that would be great. If it's a premium plugin then if you could provide either:

    Thank you all, you can post here (no login details) with any plugins you may notice that add any or submit a ticket, or shoot me a PM.
     
  2. ModeltogTossen

    ModeltogTossen Customer

    30
    12
    8
    Hi Russ..

    I would like to give some feedback as I'm one of those with this little issues with extra added editor buttons. In my case I have Sonnb's XenGallery add-on and have one options to enabled those extra icons to editor - they looks broken. I have created another posts in customer support about that.

    Now - You did reply to that and I did try to solved it with the link you gave me. What I found and added was this:

    Code:
    Copy Source
    html .redactor_toolbar li a.redactor_btn_insertAlbum:before {content: "\f115";}
    html .redactor_toolbar li a.redactor_btn_insertContent:before {content: "\f083";}
    But is still 'broken' in some way - when I hover over the button I do se the content value icon in place - but something else is in place again after moving focus away.

    upload_2016-1-12_14-3-40.png

    The second last shows you what to see when hover over it and the last one has this 'something else' ..

    Hope you can use it to find out something. Besides of that - I love your work..
     
  3. Mason K.

    Mason K. Member

    87
    14
    8
    Ohh.... I thought this was a problem on my end. I was going to ask Brogan why my CTA float BB Code wasn't showing up in my style. Also my Apple BB Code by xen-factory isn't showing it's icon. Is there a fix for these two free add-ons in the meantime?
     
  4. Russ

    Russ Designer

    8,450
    1,949
    113
    Try this in your extra.css:

    Code:
    Copy Source
    html .redactor_toolbar li a.redactor_btn_container_custom_apple:before {content: "\f179";}
    html .redactor_toolbar li a.redactor_btn_container_custom_float_left:before {content: "\f100";}
    html .redactor_toolbar li a.redactor_btn_container_custom_float_right:before {content: "\f101";}
     
  5. Mason K.

    Mason K. Member

    87
    14
    8
    It didn't work....
     
  6. Russ

    Russ Designer

    8,450
    1,949
    113
    I looked at the code wrong(I edited it on your site from account that was active. This is the correct code:

    Code:
    Copy Source
    html .redactor_toolbar li a.redactor_btn_custom_apple:before {content: "\f179";}
    html .redactor_toolbar li a.redactor_btn_custom_float_left:before {content: "\f100";}
    html .redactor_toolbar li a.redactor_btn_custom_float_right:before {content: "\f101";}
     
  7. Mason K.

    Mason K. Member

    87
    14
    8
    No problem Russ, it now works like a charm and now I know how to resolve this problem if it happens in the future. Thanks!
     
  8. bt012ss

    bt012ss Active Member

    111
    47
    28
    Hi Russ, i use sonnb´s gallery and have the same problem.
    a blank field by mouseover.
    pixel11.jpg
     
  9. Russ

    Russ Designer

    8,450
    1,949
    113
    Try this in extra.css:

    Code:
    Copy Source
    html .redactor_toolbar li a:hover { background-image: none !important; }
    Not sure if that works, I gave it to someone to test the other day but I haven't heard back.
     
  10. bt012ss

    bt012ss Active Member

    111
    47
    28
    Thanks, but for me it will not run, the same as before.
     
  11. ModeltogTossen

    ModeltogTossen Customer

    30
    12
    8
    I did also applied this - and still the same - will create a ticket or maybe we much have Sonnb in play? ..

    Edit: Tickets created and posted
     
    Last edited: Jan 19, 2016
  12. Steve

    Steve Designer

    1,601
    394
    83
    This is the fix, keep what @Russ posted as well.
    Code:
    Copy Source
    html .redactor_toolbar li a {
        background-image: none !important;
    }
    upload_2016-1-19_9-1-47.png
     
    Souupy and ModeltogTossen like this.
  13. ModeltogTossen

    ModeltogTossen Customer

    30
    12
    8
    Confirm it - very nice and thank you so very much @Steve ..
     
    Steve likes this.
  14. Mason K.

    Mason K. Member

    87
    14
    8
    Also KL post templates isn't displaying an icon.
     
  15. bt012ss

    bt012ss Active Member

    111
    47
    28
    For what please?
    This code disables the icons of sonnb´s gallery in the editor.
     
  16. Russ

    Russ Designer

    8,450
    1,949
    113
    Sorry use @ModeltogTossen fix in he second post of the thread.

    I will make sure we cover a lot of buttons in our next release.
     
  17. ModeltogTossen

    ModeltogTossen Customer

    30
    12
    8
    In my case I have activated using of awesome font icons in the editor - thats why I did have issues... I found those extra .redactor_toolbar, as written about here - https://pixelexit.com/threads/need-some-feedback-editor-icons.3285/#post-17346 - and applied the fix from @Steve and @Russ and that did fix it for me - so I now have 2 awesome font icons for sonnb's xengallery editor icon. All is good, at least for me.
     
    bt012ss likes this.
  18. bt012ss

    bt012ss Active Member

    111
    47
    28
    Upps, i understand. Sorry for my post :(
     
  19. Russ

    Russ Designer

    8,450
    1,949
    113
    I've gone ahead and added quite a bit of icons in for the next release of XenBase. I've also reached out to some of the add-on authors to double check if any of their add-ons do add icons into the editor so I can support it. Additionally I've added a fix to help with the double icons showing up
     
    Alfa1 likes this.
  20. Zynektic

    Zynektic Member

    209
    15
    18

Share This Page