XF 1.x Outdated template in parent style after XF update

abdfahim

Registered
What to do about this? I haven't touch anything in the parent styles.

But I installed EDGE while I was on XF1.5.10, and then I updated my XF to 1.5.12 today.



upload_2017-3-4_13-43-14.png
 

Steve

Pixel Exit Staff
Edge was made on XenForo 1.5.12 so importing it into an older version causes this. You can reimport the styles and see if the outdated templates get fixed now that you're on 1.5.12.
 

abdfahim

Registered
Can you please elaborate how can I reimport? Should I just reupload all the files, and then import the xml (e.g. just like a new installation)?

If I do so, do I loose all the template modifications and style properties modifications I have done so far?
 

Steve

Pixel Exit Staff
No need to upload files again.

You can import the xml's again. You will end up with 2 of each style installed, then you can manually copy your changes over to the new style from the old one. The only way it can be done.
 

abdfahim

Registered
No need to upload files again.

You can import the xml's again. You will end up with 2 of each style installed, then you can manually copy your changes over to the new style from the old one. The only way it can be done.
Oh, does that mean I should NOT overwrite the existing Xenbase and EDGE, instead import as a new style? I was thinking of following the upgrade process described here (which asks to overwrite).

I also have a question. In future, every time you release an update of EDGE/Xenbase, do I need to manually set all the style properties and template modifications (of my child theme) after I import the new XB/EDGE?
 

abdfahim

Registered
I actually tried in my local installation to reimport and overwrite the existing XB/EDGE, and my template modifications and style properties remained intact. That means if I overwrite, I don't have to reapply my modifications manually. Can you please confirm?

So, are you saying overwriting XB/EDGE is not going to solve the outdated template issue? I really don't want to manually reapply all my modifications and style properties again. There are a lot :(.
 

Steve

Pixel Exit Staff
When you overwrote it on your local install did it fix the outdated templates?
 

abdfahim

Registered
Actually, I didn't have any outdated templates in local install (I installed XB directly on latest XF). I just wanted to see if overwriting cause an issue to my custom modifications. The next trial would be to install XB on old XF, and update XF to simulate my server situation.

But just before that, want to confirm is it worth trying overwriting in the server to check if the issue solves (as I don't have to take those extra pain of applying custom modifications manually).

Sorry, I have no idea how XF style installation/upgrades works, so my question can be real lame.
 

abdfahim

Registered
Right ... overwriting haven't solve the outdated template issue ..... (why's that?).

Anyway, going to follow your previous advice.
 

Steve

Pixel Exit Staff
Can you compare the outdated templates to some default ones and see if they're actually outdated? You may get away with just saving the templates. Though you can export your style and then reimport under a newly imported XenBase.
 

abdfahim

Registered
I'll check that with a default one.

However I feel hopeful with your last comment :). So if I export my current child (let say "abdfahim-edge"), reimport XB and EDGE, and then import "abdfahim-edge" as a child of new EDGE, will all my custom modifications of "abdfahim-edge" remain intact?
 

Pre-Sale Questions

If you have any questions or concerns you want to ask before you make a purchase don't hesitate to use one of our multiple support channels for your convenience.