XF 1.X Outdated templates: message_user_info, message_user_info.css, sidebar.css

jflory7

Well-Known Member
#1
Hey PixelExit team,

Problem
I just followed the 1.5.9 upgrade installation guide for XenBase and my theme, Legendary. I had a few outdated themes, as usual, and went to automatically merge them, but found that a few were not wanting to automatically merge.


Background analysis
This is similar to the problem in this thread. Here's some screenshots of the pages in my outdated templates, if they are useful.





Disclaimer on this one… I don't hold a current license on Splash. But if this is some minor, easily fixable issue, it would be nice to merge the template change in. If it's something more fundamental or involves major changes since the version I have, I understand if no support can be provided here…

Proposed solution
Ultimately, it would be nice to have a quick solution to the problem involving changing a few lines, like was the case last time. I also don't know what information is helpful to you all beyond these screenshots, so if more info is needed, tell me what to grab and I'll get it in this thread. Thanks for your time!

Cheers,
- jflory7​
 

Russ

Pixel Exit Staff
#2
Are you running XenForo 1.5.9? That is required as per the upgrade notes on this version. Those templates are not outdated using the latest XML's and running on 1.5.9
 
#3
I also have this issue most times, but I just open the template that wont auto merge, click save, then merge at the top.
Is that wrong then?
 

Russ

Pixel Exit Staff
#4
If you upgrade XenForo first, then import our latest style that matches the XenForo version you shouldn't have outdated templates on XenBase or the purchase style like the screenshots shown above. Doing it like this only time you'll get outdated templates is if you have customized a template on your child style which we updated in the patch.
 

jflory7

Well-Known Member
#5
Are you running XenForo 1.5.9? That is required as per the upgrade notes on this version. Those templates are not outdated using the latest XML's and running on 1.5.9
I definitely upgraded to 1.5.9 before uploading or importing any XenBase/Legendary styles. Thinking about it, I didn't try auto-merging my templates immediately after upgrading, I upgraded/installed the new XenBase/Legendary right afterwards, and then went to merge. Is that order wrong?
 

Russ

Pixel Exit Staff
#6
I see what may be happening, when I mentioned to install it as a brand new style the new styles should show the names as:

XenBase ( PARENT DO NOT EDIT)
- Splash ( PARENT DO NOT EDIT)

Are you sure the outdated templates aren't your old 1.5.7 version?
 

jflory7

Well-Known Member
#7
I see what may be happening, when I mentioned to install it as a brand new style the new styles should show the names as:

XenBase ( PARENT DO NOT EDIT)
- Splash ( PARENT DO NOT EDIT)

Are you sure the outdated templates aren't your old 1.5.7 version?
Yeah, I uploaded them like this. The above one is my old one.
 

Russ

Pixel Exit Staff
#8
The Splash (Master) isn't from the package, but the old style which is why it could be showing as outdated. Import the new splash xml from the latest 1.5.9 and overwrite Splash (Master).

Next you need to open up the template that shows outdated under legendary, click "View custom changes" and see what you're missing. If you haven't made changes to that template you could revert it or click SAVE AND EXIT

After you do that only the old xenbase should show having outdated templates.

If you need help too I can help real quick via a temporary login (not posted here as it's public :D but via a support ticket).
 

jflory7

Well-Known Member
#9
The Splash (Master) isn't from the package, but the old style which is why it could be showing as outdated. Import the new splash xml from the latest 1.5.9 and overwrite Splash (Master).
Ah, yeah, sorry, not sure if you caught my note in the above:
Disclaimer on this one… I don't hold a current license on Splash. But if this is some minor, easily fixable issue, it would be nice to merge the template change in. If it's something more fundamental or involves major changes since the version I have, I understand if no support can be provided here…
In that case, don't worry about Splash. I might purchase a renewal for it later on since a lot of my users still seem to enjoy using that theme. It's been a few releases since I've updated it.

After you do that only the old xenbase should show having outdated templates.

If you need help too I can help real quick via a temporary login (not posted here as it's public :D but via a support ticket).
I'll go ahead and open one now. Thanks!
 

Pre-Sale Questions

If you have any questions or concerns you want to ask before you make a purchase don't hesitate to use one of our multiple support channels for your convenience.