XF 1.x post new thread issue?

BlackSS

Registered
Hi,
When i tick this part:
Shift Call-To-Action out of breadcrumb
Shifts the call-to-action button(post new thread) to the right side of the page title area

This works and does move the new thread inline with title.
How ever, it doesn't work when sub-forums are active.

I moved my sub forums to the bottom with this edit in forum view:
Code:
<xen:if is="{$renderedNodes}">
<xen:include template="node_list" />
</xen:if>

I thought this may have caused the issue, but when i checked the do not edit style, the post new thread is still not next to the title. Im wondering if this is normal please? If not, id love to have the post new thread next to the title with sub forums active.
Thanks.
1nosub.jpg 1nsub.jpg 1nsub2.jpg
 

Russ

Pixel Exit Staff
So I think XF made this choice so it doesn't seem like the post thread would be above the sub-nodes to think the user would post in there.

But easy adjustment:

Forum_view template, find:

Code:
<xen:if is="{$canPostThread}">
    <xen:set var="$newDiscussionButton"><a href="{xen:link 'forums/create-thread', $forum}" class="callToAction"><span>{xen:phrase post_new_thread}</span></a></xen:set>
    <xen:if is="!{$renderedNodes}">
        <xen:topctrl>{xen:raw $newDiscussionButton}</xen:topctrl>
    </xen:if>
</xen:if>

Remove the renderedNodes conditional:

Code:
<xen:if is="{$canPostThread}">
    <xen:set var="$newDiscussionButton"><a href="{xen:link 'forums/create-thread', $forum}" class="callToAction"><span>{xen:phrase post_new_thread}</span></a></xen:set>
        <xen:topctrl>{xen:raw $newDiscussionButton}</xen:topctrl>
</xen:if>

Then if you want to hide the second one below the sub-forums:

Code:
<xen:if is="{$newDiscussionButton}">
        <div class="nodeListNewDiscussionButton">{xen:raw $newDiscussionButton}</div>
    </xen:if>

Right below:
Code:
  <xen:include template="node_list" />
 

BlackSS

Registered
Awesome mate thanks. There ended up being 2 post thread buttons at the top.
So i removed this:
Code:
<div class="nodeListNewDiscussionButton">{xen:raw $newDiscussionButton}</div>
So the code now is this:
Code:
<xen:if is="{$renderedNodes}">
    <xen:include template="ad_forum_view_above_node_list" />
        <xen:if is="{$newDiscussionButton}">
    </xen:if>

It works ok, should be fine?
As i couldn't find this code in Forum_view template.
Code:
<xen:if is="{$newDiscussionButton}">
        <div class="nodeListNewDiscussionButton">{xen:raw $newDiscussionButton}</div>
    </xen:if>

Thanks man ;)
 

Pre-Sale Questions

If you have any questions or concerns you want to ask before you make a purchase don't hesitate to use one of our multiple support channels for your convenience.