Russ

Pixel Exit Staff
I'm wrapping up the final touches on the updates for the styles, it will take me a bit to complete though. The update is a rather large update in terms of bug fixes, usability, and overall improvements. It has taken a while because as always I've wanted to make sure the updates go over as smoothly as possible.

If you're running the latest version of our styles you'll have two outdated templates when you upgrade to 2.1.4. The two templates are:

node_list.less
thread_list_macros

I normally don't do this but if you're anxious to get those outdated templates cleared before I push my updates, feel free to edit the main parent style (the one that says DO NOT EDIT). It's ok to edit it in this case, by doing this you won't need to fix anything when you upgrade the style.

To fix the outdated templates
For node_list.less, go to line 233, find this bit:

Code:
    .node-main
    {
        display: block;
        width: auto;
    }
Replace with:

Code:
    .node-main
    {
        display: block;
        width: auto;

        .node--link &,
        .node--page &
        {
            // #168882: we only display the title for these types
            // so keep these as table-cells for vertical alignment
            display: table-cell;
        }
    }
Hit SAVE AND EXIT

Next, open thread_list_macros, go to line 165

Find:

Code:
<a href="{{ link('threads/edit', $thread) }}" data-xf-click="overlay" data-href="{{ link('threads/edit', $thread, $editParams) }}"

Replace with:

Code:
<a href="{{ link('threads/edit', $thread) }}" data-xf-click="overlay" data-cache="false" data-href="{{ link('threads/edit', $thread, $editParams) }}">
That's it, I'm excited to get these updates out. Thank you for your patience.
 

Russ

Pixel Exit Staff
Any update on this, @Russ?
Not yet, a rather annoying bug I'm working with someone to get it resolved (involving all of our toggle options).

The first post is easy to do to clear those outdated templates. If you need help just submit a ticket and I can get that sorted.
 

Davey

Registered
Waiting patiently.......... Deciding whether to revamp my style or try a new one like Evolve. Need to see the changes / updates first. 🤔
 
Updated to XenForo 2.1.15 today, and all seems well and compatible with the FlatAwesome.

EDIT: Indeed, no outdated templates since the above modifications were done. Everything "just worked"
 

Russ

Pixel Exit Staff
Updated to XenForo 2.1.15 today, and all seems well an d compatible with the FlatAwesome.
Yep no outdated templates (assuming you applied the edits above).

I'll be sending out style updates... today I believe. They will not include new features/bug fixes but simply fix the outdated templates from 2.1.4.

I should be posting our own little "Have you seen" thread about some upcoming improvements to our styles.
 

Pre-Sale Questions

If you have any questions or concerns you want to ask before you make a purchase don't hesitate to use one of our multiple support channels for your convenience.