JacquiiDesigns

Registered
Hey guys. There seems to be an issue with the help pages navigation. Once enabled to show in the main navigation menu - I see the main 5 quick link options in the dropdown menu. I, however, have added a few additional pages as seen in the screencap below. The main issue, though, is that you can see none of them in the actual sub-navigation menu.

helppages-dropdown.png


helppages-nav.png


helppages-submenu.png

Can you suggest an option or options so that
  1. The quick links dropdown shows all, including the additional pages and
  2. The sub-navigation menu shows all the help pages
Even if it's not an option in the actual Xenbase framework - if you can suggest the appropriate template edits I'll very much appreciate it.

Thanks!

J.
 

Russ

Pixel Exit Staff
If I recall when I previously looked it wasn't possible with the new help page setup. You can add them manually:

xb_nav_help
 

JacquiiDesigns

Registered
Thanks Russ. I thought there'd be a bit of template editing to get what I want actually accomplished.
More work LOL. Anyway - thanks for the reply ;)

J.
 

JacquiiDesigns

Registered
Hey @Russ - I've edited my xb_nav_help template to read:
HTML:
<ul class="secondaryContent blockLinksList">
            <xen:hook name="help_sidebar_links">
            <li><a href="{xen:link help/about-us}">{xen:phrase help_jpicabout}</a></li>
            <li><a href="{xen:link help/jpic-posting-policy}">{xen:phrase help_jpicposting}</a></li>
            <li><a href="{xen:link help/staff}">{xen:phrase help_jpicmoderating}</a></li>
            <li><a href="{xen:link help/TOS}">{xen:phrase help_jpicterms}</a></li>
            <li><a href="{xen:link help/privacy-policy}">{xen:phrase help_jpicprivacy}</a></li>
            <li><a href="{xen:link help/newbie-guide}">{xen:phrase help_jpicnewbie}</a></li>
            <li><a href="{xen:link help/link-to-jpic}">{xen:phrase help_jpiclinkto}</a></li>
            <li><a href="{xen:link help/smilies}">{xen:phrase smilies}</a></li>
            <xen:if is="{$xenOptions.enableTrophies}">
            <li><a href="{xen:link help/trophies}">{xen:phrase trophies}</a></li>
            </xen:if>
            <li><a href="{xen:link help/bb-codes}">{xen:phrase bb_codes}</a></li>
            <xen:if is="{$tosUrl}">
            <li><a href="{xen:link help/cookies}">{xen:phrase cookie_usage}</a></li>
            </xen:if>
            </xen:hook>
        </ul>
The dropdown navigation menu shows just fine. However, the tablinks (what I'd previous called the sub-navigation menu) is blank, with no links showing:
jpic-tablinks.png


Am I doing something wrong? Can you suggest a way so that the Help tablinks show like all the other menus? For instance - the Forums dropdown and tablinks show like this screencap:
jpic-tablinks_forums.png


IS there any way for the revised Help tablinks to show as the Forums' tablinks does?
Thanks for any assistance.

J.
 

JacquiiDesigns

Registered
Ah. I was afraid of that :(
But double Ah ==> I've got Nodes As Tabs already installed and I *think* it may actually present the exact solution I'm looking for! Didn't even think of that actually. It'll likely entail creating a bunch of link-forums and linking them that way. But probably they will show in the tablinks section though! IDK. But will give it a try a bit later. Thanks for the suggestion! I didn't even think of that tbh o_O

J.
 

Pre-Sale Questions

If you have any questions or concerns you want to ask before you make a purchase don't hesitate to use one of our multiple support channels for your convenience.