Sticky sidebar not working on forum_list

Discussion in 'Closed Reports' started by ToxicS, Mar 18, 2015.

  1. ToxicS

    ToxicS Customer

    Bug Report Details:
    The Sticky sidebar with Fragzone works perfectly on all Pages except Forum_list, I tested this and was able to replicate the issue with a clean xenforo installation with no addons and floating, nav, sub-nav, mod bar, etc all disabled.
    With The Xenbase style the sticky sidebar works fine on all pages.
     
  2. Russ

    Russ Designer

    How long is your sidebar on the forum index? If the sidebar is longer than the window it won't be sticky(it's how our functions).
     
  3. ToxicS

    ToxicS Customer

    i tested this with just the basic short sidebar and several forums, it's working fine on Xenbase, just not on fragzone.
     
  4. Russ

    Russ Designer

    Ok, I'll try some debugging tomororw(heading off for the night) and see what I can come up with.
     
    ToxicS likes this.
  5. Russ

    Russ Designer

    I can't actually reproduce this :(, there's no modified JS inside Frag Zone that should break it. Just make sure the height is shorter than the page(or else it won't scroll, ours is setup to work with short sidebars).
     
  6. ToxicS

    ToxicS Customer

    That is just weird, I just installed a fresh xenforo just to test this again, the sidebar is default length and i created 15 forums so it's long enough to scroll but it still won't work on Fragzone while working fine on xenbase. Sending you link in inbox.
     
  7. Russ

    Russ Designer

    Changing this to fixed :), on my version I had the breadcrumbs showing which the sticky sidebar uses to calculate when to stop, if they're disabled(like default frag zone) it would throw an error and make it not work. I've added in a conditional to fix this. Thanks!
     
    ToxicS likes this.

Let's work together on your next project

Contact us today to talk about how we can help you