Nirjonadda

Customer
Today I have updated one add-on Top Posters of the Month then Style broken. Please can you let know this fix?

Also have Server error logs:

Code:
Less_Exception_Compiler: .m-userBannerVariation is undefined in anonymous-file-6464.less src/vendor/oyejorge/less.php/lib/Less/Tree/Mixin/Call.php:148

Generated by: Unknown account Oct 5, 2018 at 3:07 AM

Stack trace

#0 src/vendor/oyejorge/less.php/lib/Less/Tree/Ruleset.php(147): Less_Tree_Mixin_Call->compile(Object(Less_Environment))
#1 src/vendor/oyejorge/less.php/lib/Less/Tree/Ruleset.php(88): Less_Tree_Ruleset->EvalMixinCalls(Object(Less_Tree_Ruleset), Object(Less_Environment), 1)
#2 src/vendor/oyejorge/less.php/lib/Less/Tree/Ruleset.php(94): Less_Tree_Ruleset->compile(Object(Less_Environment))
#3 src/vendor/oyejorge/less.php/lib/Less/Tree/Ruleset.php(94): Less_Tree_Ruleset->compile(Object(Less_Environment))
#4 src/vendor/oyejorge/less.php/lib/Less/Parser.php(199): Less_Tree_Ruleset->compile(Object(Less_Environment))
#5 src/XF/CssRenderer.php(363): Less_Parser->getCss()
#6 src/XF/CssRenderer.php(311): XF\CssRenderer->renderToCss('public:app.less', '// Note that th...')
#7 src/XF/CssRenderer.php(235): XF\CssRenderer->renderTemplate('public:app.less', NULL)
#8 src/XF/CssRenderer.php(101): XF\CssRenderer->renderTemplates(Array, Array, Array)
#9 src/XF/CssWriter.php(53): XF\CssRenderer->render(Array)
#10 src/addons/SV/RedisCache/XF/CssWriter.php(23): XF\CssWriter->run(Array, 4, 1, 'cf4caa6e751e27b...')
#11 css.php(30): SV\RedisCache\XF\CssWriter->run(Array, 4, 1, 'cf4caa6e751e27b...')
#12 {main}

Request state

array(4) {
  ["url"] => string(140) "/css.php?css=public%3Anormalize.css%2Cpublic%3Acore.less%2Cpublic%3Aapp.less&s=4&l=1&d=1538687225&k=cf4caa6e751e27b4e051b52eae07eb828eb0bfb5"
  ["referrer"] => string(23) "/"
  ["_GET"] => array(5) {
    ["css"] => string(53) "public:normalize.css,public:core.less,public:app.less"
    ["s"] => string(1) "4"
    ["l"] => string(1) "1"
    ["d"] => string(10) "1538687225"
    ["k"] => string(40) "cf4caa6e751e27b4e051b52eae07eb828eb0bfb5"
  }
  ["_POST"] => array(0) {
  }
}
 

Russ

Pixel Exit Staff
I see something we can do to help here....

for now, open tpm.less template, add the following to the top of the template:

Code:
.m-userBannerVariation(@color; @bg; @border: false)
{
    color: @color;
    background: @bg;
    border-color: xf-intensify(@bg, 10%);

    & when (iscolor(@border))
    {
        border-color: @border;
    }
}
 

Nirjonadda

Customer
So this is style issue or add-on issues? If add-on issue then I will do bug reports to add-on developer. But others styles does not have this issue with this add-on.
 

Russ

Pixel Exit Staff
We have an option to replace all of the banners in XenForo which use our custom properties. By doing so we remove a specific code that isn't required and that's causing the problem here. We can leave that code in and not cause any conflict, so you don't need to alert the developer of the add-on, we'll fix it on our level next release. Next patch you can just revert the changes I posted above.
 

Russ

Pixel Exit Staff
Any style of ours that you use, you can just place it in the child style.
 

Russ

Pixel Exit Staff
Did you apply the edit directly to your child style like I mentioned? It shouldn't show outdated if you did that.

You didn't make it to the parent style also did you?
 

Russ

Pixel Exit Staff
Well, if you open the template, click SAVE AND EXIt it should technically clear it. If it's not it's probably due to the XF bug that's been around for while: https://xenforo.com/community/threads/template-versions-not-updating-when-saving.147575/

If you can't handle having that outdated template message (it doesn't cause any harm what so ever), revert the template and go to: Style Properties -> User banners, uncheck our XenBase user banners.
 

Russ

Pixel Exit Staff
Actually... I'd say the add-on may want to add this missing class:

Screenshot_4.png



It displays banners in the message area as blocks and adds a small margin.

For your setup you could add this in extra.less until the developer addresses it:

Code:
.userBanner.userBanner--tpm {
    display: block;
    margin-top: 3px;
}
 

Frode789

Customer
Actually... I'd say the add-on may want to add this missing class:

View attachment 8590


It displays banners in the message area as blocks and adds a small margin.

For your setup you could add this in extra.less until the developer addresses it:

Code:
.userBanner.userBanner--tpm {
    display: block;
    margin-top: 3px;
}
Thank you!
 

Pre-Sale Questions

If you have any questions or concerns you want to ask before you make a purchase don't hesitate to use one of our multiple support channels for your convenience.