XF 1.x Upgrade from Zipped 1.4.4 to 1.5.3

daimpa

Customer
Hello, I'm upgrading the forum and need a clarification to update the theme (I've updated XF to 1.5.5a).

"To upgrade you'll need to upload the new XenBase folder first. Next you'll import XenBase-xml, overwriting your current XenBase Style. Finally import and overwrite your paid style(Fusion Gamer/Core/Apex ect...)."

What do you mean with the part in bold? Should we import the zipped folder, the zipped XML or both?

Also, I'm using a child style. I made several changes to properties and templates. Will I lose those changes? Thanks :)
 

nome

Registered
What do you mean with the part in bold? Should we import the zipped folder, the zipped XML or both?
Upload the unzipped folders to their proper place then import the unzipped XMLs.

Also, I'm using a child style. I made several changes to properties and templates. Will I lose those changes? Thanks :)
No you won't. lose them.
 

daimpa

Customer
Upload the unzipped folders to their proper place then import the unzipped XMLs.


No you won't. lose them.
Hi, first of all thanks For the reply. To be sure, with "Zipped" I meant the name of the theme. So, to confirm, should I upload also the folder and the XML of the theme other than the xenbase files/xml?

About the changes, at the moment I've uploaded only xenbase files/xml and the color of the text in the top menu changed..
 

nome

Registered
So, to confirm, should I upload also the folder and the XML of the theme other than the xenbase files/xml?
From your computer upload "styles" to the site's "styles" (overwrite the existing files)
Then in the ACP "Import a File" the xml file "style-XenBase.xml" and "style-Zipped.xml" "Overwrite style".
It's not necessary to upload the xml files, you can import them from your computer.
 

Russ

Pixel Exit Staff
Side note, backup your styles!

1.4.x -> 1.5.x is a rather huge change for our framework in regards to certain things.
 

daimpa

Customer
Thanks for your reply.

Is it normal that after the update, some of the properties of my child theme are changed?
This is my structure:
Xenbase->Zipped->Child.

I made all the modifications in Child.

Now, when I check for example "Message Elements->Generic Attachment Thumbnail" the img value before the update was @imagePath/xenforo/node-sprite.png, now it's empty.
 

Russ

Pixel Exit Staff
Thanks for your reply.

Is it normal that after the update, some of the properties of my child theme are changed?
This is my structure:
Xenbase->Zipped->Child.

I made all the modifications in Child.

Now, when I check for example "Message Elements->Generic Attachment Thumbnail" the img value before the update was @imagePath/xenforo/node-sprite.png, now it's empty.
Some things were switched off by default yes. Regarding the thumbnail we ditched it for a Font Awesome icon instead of the normal sprite. Ideally we try to minimize any change but going from 1.4.4 -> 1.5.3 was a rather dramatic update.

Let me know if you have any other questions.
 

daimpa

Customer
Regarding the thumbnail we ditched it for a Font Awesome icon instead of the normal sprite.
Leaving it blank, this is what I see in my local environment. Is this as it should be?

Screenshot (92).png


I've another question. Which is the difference between "Enable Sidebar Login Form" and the default option? I've enabled it and it seems only a layout change.
 

Russ

Pixel Exit Staff
Zipped originally came with it's own custom login form, that has been replaced for the default XenBase one in the next version. It's coded slightly better and should look good on any style.

As for the attached files... double check your xb_message.css isn't customized/outdated. We add some CSS to add in icons there

Screenshot_4.png
 

daimpa

Customer
Screenshot (93).png It isn't customized/outdated. I've tested your public demo and I see exactly the same icon as in the pic I sent to you.
 

daimpa

Customer
Just to confirm, is it only my problem or a little mistake in the template like it seems from the public demo? Need a reply so I can install the theme in the live version of the site :)
 

Russ

Pixel Exit Staff
I just tried on the demo site and it worked

Do any other font awesome icons like the editor icons in my screenshot load for you?


Ah I see the problem one moment
 

Attachments

Russ

Pixel Exit Staff
Ok so xb_messages.css is only being called on the message level, so once you leave that template such as the more options page it's not loading the CSS. I've adjusted this for the 1.5.6 release but if you want to change it now... you can just add this portion to your extra.css:

Code:
.XenBase .attachment .thumbnail .genericAttachment, .XenBase .AttachmentEditor .AttachedFile .Thumbnail .genericAttachment
{
   background-image: none;
   line-height: @genericAttachmentThumb.height;
   text-align: center;
}
.XenBase .attachment .thumbnail .genericAttachment:before, .XenBase .AttachmentEditor .AttachedFile .Thumbnail .genericAttachment:before
{
   color: @contentText;
   content: "\f019";
   font-family: FontAwesome;
   font-weight: normal;
   font-size: 32px;
   margin-left: 5px;
}
.XenBase .AttachmentEditor .AttachedFile .Thumbnail .genericAttachment:before
{
   content: "\f093";
}
I'm hoping to have the next update out in the next couple days for all the styles if you want to wait for that.
 
Last edited:

daimpa

Customer
Ok so xb_messages.css is only being called on the message level, so once you leave that template such as the more options page it's not loading the CSS. I've adjusted this for the 1.5.6 release but if you want to change it now... you can just add this portion to your extra.css:

Code:
.XenBase .attachment .thumbnail .genericAttachment, .XenBase .AttachmentEditor .AttachedFile .Thumbnail .genericAttachment
{
   background-image: none;
   line-height: @genericAttachmentThumb.height;
   text-align: center;
}
.XenBase .attachment .thumbnail .genericAttachment:before, .XenBase .AttachmentEditor .AttachedFile .Thumbnail .genericAttachment:before
{
   color: @contentText;
   content: "\f019";
   font-family: FontAwesome;
   font-weight: normal;
   font-size: 32px;
   margin-left: 5px;
}
.XenBase .AttachmentEditor .AttachedFile .Thumbnail .genericAttachment:before
{
   content: "\f093";
}
I'm hoping to have the next update out in the next couple days for all the styles if you want to wait for that.
Great, thanks for your help and patience! :)
 

Pre-Sale Questions

If you have any questions or concerns you want to ask before you make a purchase don't hesitate to use one of our multiple support channels for your convenience.