Hamma

Active Member
I just did a fairly significant upgrade to 1.4.3 from a pretty ancient version (1.2.3) and I followed all the required instructions. (New style, find and replace etc). I seem to be missing my Userbar at the top and cannot figure out how to bring it back. I have the User Panel disabled. Thoughts?
 

Attachments

Hamma

Active Member
Also I am using Xenporta2 and the recent news graphics slider is half the size it should be. :(
 

Russ

Pixel Exit Staff
For the xenporta stuff, check out Style Properties -> Sidebar, remove the !important after the width.

Check the Style Properties -> [XB] Header and Navigation -> Enable Top User Bar

Frag Zone got quite an update since the 1.2 version so things are going to look different. Let me know if you need help.
 

Hamma

Active Member
Yea I enabled that and it's still not working. When I look at the default Frag Zone I do actually see the userbar.. so it seems like I wrecked something in my substyle.. hmm.

The !important thing did work for Xenporta though!
 

Russ

Pixel Exit Staff
More than likely it's one of the following templates which were edited on your custom style:

page_container
moderator_bar

If it shows outdated on those try using the merge tool via Outdated Templates

If it shows no outdated templates but they are customized, open each template, copy them... then click revert. Now what I do in this scenario is use a program like Notepad++, paste the old template and the new template and run a compare on them. 1.2 -> 1.4 and add any edits you may have back in there was some pretty big changes in the page_container template.
 

Hamma

Active Member
Ok cool - let me give that a shot a bit later today. Thank you for all your help in this! Support is awesome here :)

I'll keep more up to date from here on.. haha. I'd imagine smaller revision updates are a bit easier to manage.
 

Russ

Pixel Exit Staff
Ok cool - let me give that a shot a bit later today. Thank you for all your help in this! Support is awesome here :)

I'll keep more up to date from here on.. haha. I'd imagine smaller revision updates are a bit easier to manage.
Ya around 1.2/1.3 the styles got a massive update, depending on how many customizations you have it was easier to start from fresh heh. But we're always here :) let us know if you need any further help.
 

Hamma

Active Member
Thanks Russ :)

Looks like reverting page container did the trick. I didn't see anything that I specifically changed in there so it was safe to revert.. looked like mostly XenBase stuff.. I am now seeing the user bar.

I only see two more that are out of date I will have a closer look at. Thanks again!
 

Russ

Pixel Exit Staff
Thanks Russ :)

Looks like reverting page container did the trick. I didn't see anything that I specifically changed in there so it was safe to revert.. looked like mostly XenBase stuff.. I am now seeing the user bar.

I only see two more that are out of date I will have a closer look at. Thanks again!
Good to hear let us know if you need anything else :)
 

Russ

Pixel Exit Staff
Two new questions:

  1. How do I change the button color? (See attached)
  2. Where in the world is @xb_fontsizes set? I am totally failing to find it.
Attached pic.
1.) It uses a css3 gradient, check style properties -> Buttons -> Button(misc field)
2.) [XB] General Setup
 

Hamma

Active Member
Awesome! Got the button - thanks for the quick response.

How does it determine which size font it is using on certain pages?
 

Russ

Pixel Exit Staff
Awesome! Got the button - thanks for the quick response.

How does it determine which size font it is using on certain pages?
Basically XenForo by default hard codes font sizes around the entire style. All we've done is gone in and replaced them with 3 different ones, s /m l.

it's more of a general helper than a one trick pony type thing.
 

Hamma

Active Member
Awesome :)

One last Q for now, where is the color of the font on top of the button defined?
 

Russ

Pixel Exit Staff
Awesome :)

One last Q for now, where is the color of the font on top of the button defined?
On top of the button? Could you clarify? The button color is controlled in the same spot I showed you but just the color setting.
 

Hamma

Active Member
Ah alright - sorry eyes started to glaze over last night. I think I am in a good place now thank you for all your help.
 

Pre-Sale Questions

If you have any questions or concerns you want to ask before you make a purchase don't hesitate to use one of our multiple support channels for your convenience.