Not a Bug whats causing this error ?

Discussion in 'Closed Reports' started by lub0112, May 17, 2018.

  1. lub0112

    lub0112 Customer

    Code:
    Copy Source
    Less_Exception_Chunk: ParseError: Unexpected input in anonymous-file-561.less on line 1514, column 5 1512| 1513| .XenBase .block--messages .message .message-content .bbCodeBlock-title a, .XenBase .block--messages .message .message-content .bbCodeBlock-title a:hover { 1514| c@media (max-width: 650px) { .XenBase .xb-footer { display: none; } } 1515| /////// 1516| @media (max-width: 650px) 1517| { src/vendor/oyejorge/less.php/lib/Less/Parser.php:677

    Code:
    Copy Source
    Stack trace
    #0 src/vendor/oyejorge/less.php/lib/Less/Parser.php(621): Less_Parser->GetRules(NULL)
    #1 src/vendor/oyejorge/less.php/lib/Less/Parser.php(449): Less_Parser->_parse()
    #2 src/XF/CssRenderer.php(363): Less_Parser->parse('// Note that th...')
    #3 src/XF/CssRenderer.php(311): XF\CssRenderer->renderToCss('public:extra.le...', '// Note that th...')
    #4 src/XF/CssRenderer.php(235): XF\CssRenderer->renderTemplate('public:extra.le...', NULL)
    #5 src/XF/CssRenderer.php(101): XF\CssRenderer->renderTemplates(Array, Array, Array)
    #6 src/XF/CssWriter.php(53): XF\CssRenderer->render(Array)
    #7 css.php(30): XF\CssWriter->run(Array, 13, 1, 'ebe00f180085647...')
    #8 {main}

    Code:
    Copy Source
    Request state
    array(4) {
      ["url"] => string(296) "/forum/css.php?css=public%3Aalnb_navigation.less%2Cpublic%3Alightbox.less%2Cpublic%3Arating_stars.less%2Cpublic%3Ashare_controls.less%2Cpublic%3Ath_reactions.less%2Cpublic%3Axb_footer.less%2Cpublic%3Axfrm.less%2Cpublic%3Aextra.less&s=13&l=1&d=1521312796&k=ebe00f1800856473809d81d50978152522c01f39"
      ["referrer"] => string(65) "https://tictalk.co.uk/forum/resources/celtic-invincibles-dvd-3.5/"
      ["_GET"] => array(5) {
        ["css"] => string(182) "public:alnb_navigation.less,public:lightbox.less,public:rating_stars.less,public:share_controls.less,public:th_reactions.less,public:xb_footer.less,public:xfrm.less,public:extra.less"
        ["s"] => string(2) "13"
        ["l"] => string(1) "1"
        ["d"] => string(10) "1521312796"
        ["k"] => string(40) "ebe00f1800856473809d81d50978152522c01f39"
      }
      ["_POST"] => array(0) {
      }
    }
    Screen Shot 2018-05-17 at 17.57.16.png
     
  2. Russ

    Russ Designer

    I'd need a login to try to debug it. Can you provide one via a ticket?
     
  3. lub0112

    lub0112 Customer

    sure
     
  4. Russ

    Russ Designer

    This was down to some bad CSS. Unfortunately, with XF2 you miss a ; on some CSS it can throw a server error.
     

Let's work together on your next project

Contact us today to talk about how we can help you

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.